KMP3D

From Custom Mario Kart
Jump to: navigation, search
KMP3D
Author: zatchi
Platform: SketchUp 6+
Programming language: Ruby
Software Type: SketchUp Plugin
File Formats: Wiimms SZS Tools's textual representation of KMP.
Current Version: v4.0
Download: GitHub

Overview

KMP3D is a SketchUp plugin made by zatchi that functions as a 3D interface for Mario Kart Wii's KMP files, which deal with coordinate information, such as check points, item routes or respawn point positions. Points are represented using spheres and vectors, depending on the point type.

Credits

  • Beaglebark413, for the item box model used as a placeholder for other objects.

Installation

For SketchUp 2013-2016

  1. Download the .rbz file.
  2. In SketchUp, go to Window -> Preferences -> Extensions -> Install Extension..., and select the file.

For SketchUp 2017+

  1. Download the .rbz file.
  2. In SketchUp, go to Window -> Extension Manager -> Install Extension..., and select the file.

For SketchUp 6-8

  1. Download the .rbz file.
  2. Rename the .rbz extension to .zip.
  3. Extract the contents of the folder into the Plugins folder in SketchUp's Program Files for Windows, or Applications folder for Mac.

Tutorial

Adding and combining points

  • Points can be added to the model by pointing and clicking in the desired area. If a given type of point is a vector, the second click determines what direction the point is facing in the horizontal (x-z) plane. Points will automatically take the settings from the previous point.
  • Points can similarly be combined, if points are different types. This can be done by hovering over a point of a different type and clicking on it. Note: the order of the point for either type will be at the time the former point was placed.

Editing points

  • Points can be translated, rotated, and scaled using any SketchUp tool or plugin. When exporting, KMP3D will automatically adjust for these changes.
  • Settings can be edited through the use of input tables. Settings mostly follow KMP Cloud's naming and organization.

Selecting points

  • Points can be selected and deselected either by clicking on the points in SketchUp, or in the input table's ID section. From here, any normal SketchUp operation can be done on them.

Exporting KMP3D points

  • Exporting KMP3D points can be done under Plugins -> KMP3D -> Export WKMPT...
  • Files can be converted through downloading and installing Wiimms SZS Tools, and using the wkmpt encode command.

Version History

Version Date of release Information
v1.0 2016-09-31 First release
v2.0 2017-01-15
  • Remade the entire interface.
  • Added ability to edit multiple points.
  • Added ability to import objects.
  • Added ability to rotate/scale points with a tool.
v3.0 2017-07-03
  • Improved interface.
  • The "Add Point" input box can be changed while in use.
  • Added ability to create cannon points and check points.
  • Fixed export and edit bugs.
v4.0 2019-11-03
  • Remade the entire interface.
  • Fixed compatibility issues.
By the same author: zatchi

Custom Tracks:
Sea Stadium

Software:
KMP3D