Porting Tutorial

From Custom Mario Kart
Jump to: navigation, search

Introduction

This tutorial will explain you how to export a track from any other 3D Mario Kart Game. If you are following the Custom Track Tutorial and making a level from scratch, proceed to the Modeling Tutorial.

If part of this article is unclear or hard for you to follow, you can ask questions on the Discussion page. Someone will attempt to clarify things for you and possibly edit the tutorial so it will be easier to understand.

The following will tutorials will explain step-by-step how to get your models in both Google SketchUp and 3ds Max if possible, and how to convert Max files to SketchUp, so please follow the guide appropriate to your needs.[1] Additionally, this guide assumes you own a ROM and/or ISO image of the needed game.[2]

NOTE: The majority of these guides requires the use of 3ds Max before using Google SketchUp. It is recommended that you go ahead and only use 3ds Max if possible.

Porting From Super Mario Kart & Mario Kart: Super Circuit

There is currently not a way to rip models from both games (since these games have no 3D models), so you have to remake the track yourself using your preferred editor.

Porting From Mario Kart 64

(The following applies to most N64 games)

Required Tools

Alternative Tools

Exporting

The following will explain how to obtain your desired model from your desired game.

Setup

Download the Required Tools (if you can't get Project64, then use 1964).

Create a new folder in your hard drive named VRML (This should be C:\VRML\). This file path is set in the emulator as the place to export the VRML file and the associated BMP textures.

Open your emulator. Take a moment to locate the Options Menu (Plugins Menu in 1964), as this plays a vital role in obtaining your model. Within the Options Menu, locate "Configure Graphics Plugin", as this is where you will rip your model later on.

Go to your plugins settings and change video plugin to Nemu64 Graphics.

Next, you will need to load your N64 ROM, this can be done by simply dragging your ROM into your emulator. In game, select the course or level you wish to extract. Once the game play begins, pause the emulator immediately (This can be done by pressing hotkey F2 in Project64, or by pressing hotkey F3 1964). While the game is paused, go back to the Options Menu (Plugins Menu in 1964) and once again locate "Configure Graphics Plugin" and open it (or alternatively just use the Ctrl + V shortcut to video settings).

Within the Graphics Plugin configure menu, there is an option that reads "Export VRML". Select it and close the configuration menu. Quickly press F2 (F3 in 1964) to rip your model. This will capture one frame of animation, and create a VRML in your C:\VRML\ folder. The emulator will only capture what geometry is shown on screen, so you'll have to capture your model multiple times from different locations, but be sure not to overwrite anything captured by moving it each time to a different folder or you can also directly import it into your 3D Editor directly after capturing.

Importing

In 3ds Max

From here, importing into 3ds Max is simple. Once 3ds Max is open, select the 3ds Max logo in the top left corner. From there, select "Import". Go to your C:\VRML\ folder, and select the VRML models you have exported (at this point, they have been given the file extension .wrl), then import them into your 3ds Max Scene. Import each .wrl model into your scene until each ripped frame combined creates the whole model.

The ripping process may have some effects on your UV coordinates, which must be fixed manually using the Unwrap UVW Modifier.

In Google SketchUp

Since Google SketchUp does not support VRML, you will have to import it into another editor first.

In Blender

Open Blender, select "File" in the top left corner. Then select "Import", X3D Extensible 3D (.x3d/.wrl) (keep all the textures too, for later use!). Go to your C:\VRML\ folder, and select the VRML models you have exported (At this point, they have been given the file extension .wrl), then import them. Import each .wrl model into your scene until each ripped frame combined creates the whole model. You can also combine each model in SketchUp later.

Now you export it via: "File", "Export", 3D Studio (.3ds). Save it where you want. Now you can import the .3ds model into SketchUp.
You still have to texture it in SketchUp with the texture files that are saved with the .wrl file!

In MeshLab

If you have a 64-bit computer you will have to download a 32-bit version, none of the 64-bit versions have support for .3ds exporting.

Importing into MeshLab is simple. Once MeshLab is open, select "File" in the top left corner. from there, select "Import". Go to your C:\VRML\ folder, and select the VRML models you have exported (at this point, they have been given the file extension .wrl), then import them. Import each .wrl model into your scene until each ripped frame combined creates the whole model.

When done you can export your model as .3ds. Be sure to place it in the same folder with all the textures that have been exported together with your VRML (.wrl), otherwhise you will lose them. Now import your .3ds-model into SketchUp.

Porting From Mario Kart: Double Dash!!

The following guide applies to games using BMD/BDL models, including Double Dash.

  • If you do not have BMD/BDL models in your desired game, then this guide is not useful for you.

Required Tools

AND/OR

3ds Max Method

Optional:

  • BMD Viewer 2 (Allows you to collect shader data)
  • BrawlBox (Allows you to both import the vertex colors and use collected shader data)

Google SketchUp Method

Setup

Firstly, you need to open Dolphin. In the Dolphin window, press Browse. Select the directory containing your ISO(s), and press OK.

If you have selected the proper directory, then your game should now be displayed on the Dolphin main menu. You should then right click your game, and select "Properties" from the drop down menu. In the properties menu, you should select "Browse". This allows you to view and extract the game's files. You should look for key words within the directories of your game, such as "Luigi2.arc", which would be GCN Luigi Circuit (100cc+) in Mario Kart: Double Dash!!. Most courses or levels in the game will be located in either an ARC file. Refer to the following table for the needed tool to decompress the desired file:

  • SZS Tools can:
    • Decompress Yaz0 (SZS) files
    • Decompress .rarc, .carc and .arc files
  • Yay0 Decoder can:
    • Decompress Yay0 (SZP) files

Once you have located you level or course, extract it by right clicking it and by selecting "Extract". Extract it to the directory you choose.

The last step would be obtaining the model from this file. Use the appropriate tool to decompress your archive. The process is fairly simple, if you have a .rarc, .carc, .arc, .szs and/or .yaz0 file, download SZS Tools. SZS and Yaz0 files go into the Yaz0Dec that comes with SZS Tools, where they will be converted to .rarc. Any .rarc, .carc, or .arc, goes into RarcDump, where all of the files will be put into a folder for you to view.

Methods

From here, you can choose 2 methods: 3ds Max or Google SketchUp. If you want vertex colors and shaders in your model, then follow the 3ds Max method. Otherwise, follow the Google SketchUp method.

3ds Max Method

Unlike most other games you can rip models from, this tutorial allows you to import both vertex colors and shaders. Both are advanced lighting methods to make shadows, visual effects, and natural looking scenery. The following tutorial will explain how to extract and import both into Mario Kart Wii. If you have no plans to use either, please move onto the next section.

The following method is using 3ds Max 2010, meaning there's a chance this will not work on the latest version. If you are feeling cautious, then download 3ds Max 2010.

Plugin Setup

Firstly, you must setup the BMD Importer plugin to allow 3ds Max to import your BMD or BDL.

A version of the readme is uploaded here (source here). Ignore references to "bmodel.ms".

To set it up, you must put the bmdview.exe in the same directory as the main executable of 3ds Max. Ignore the .mcr file in that archive. Instead extract this script into a path you know, recommended to put into (<3ds Max installer folder>\scripts\MaxBMD.mcr). If it doesn't work, try using 3ds Max 2010 instead of whatever you have.

To load the plugin:

  1. Go to Maxscript → Run Script. The dialog may default to the scripts folder. If you cannot find a MaxBMD.mcr file, navigate to where you put your script earlier. Then open it.
  2. Go to Customize → Customize User Interface. Go to Toolbars tab and click the Categories dropdown menu at the left. Find and select MaxBMD. Then at the large scrollable box below, drag the "BMD Importer" item to a toolbar.
  3. Click on the new button to run the importer.
Setting Up Your Model

When your model if first imported with MaxBMD, the entire model will be grouped together and will be imported into Brawlbox as one material. To fix this use the Detatch by Material ID plugin to seperate parts of the model based on it's material.

Getting Vertex Colors & Shaders

Once your plugin is ready, you may import your BMD or BDL file.

Since the plugin supports only BMD files, simply rename your BDL file (if you have any) to BMD and continue. Otherwise, skip this step.

Continue onto Creating a BRRES with BrawlBox for a step-by-step guide on how to get your model in BRRES from using 3ds Max and BrawlBox.

Once your BRRES is ready, you may add the shader data. To do so, open your BMD/BDL in the BMD Viewer 2. Once your model is loaded, go to File menu, and select "Dump Shader Data". You should get a .txt containing the shader data from your model. This data can be added to your model with the use of BrawlBox. The .txt will refer to the shader settings in BrawlBox you can alter. Re-write the information in the .txt in BrawlBox. While settings between the BMD Viewer 2 and BrawlBox may not be exact, they are very similar, and will produce very similar results, causing your model to look as if it was directly ported from the game you had gotten it from. Next, follow the Creating Your Track section.

Google SketchUp Method

Open up your BMD/BDL file in BMD Viewer 2. Go to File → Export Model, and save as a .3ds file. When your new file is saved, open up Google SketchUp, and go to File → Import. Make sure the files of type box in the dialog are set to 3DS Files (.3ds). Then locate your file and open it. Next, follow the Creating Your Track section.

Porting From Mario Kart DS

Required Tools

Beta ROM

Open your ROM in the MKDS Course Modifier.

Go into "data → course → coursefilename.carc".

Double-click the .carc file and double-click course_model.nsbmd, and in the upper left corner, go into Export → Model → OBJ. Export the textures as PNG. Now you can import the OBJ file into your Model editor.

Official ROM

Open your ROM in the MKDS Course Modifier.

  • If you have a normal rom, go into "data → course".
  • First open FileName.carc and double click course_model.nsbmd. Now keep the window open and load FileNameTex.carc. Double click on course_model.nsbtx and you will see the model getting textured. The .nsbmd file should look like the picture below.
The GUI of the Mario Kart DS Course Modifier.


  • Now go into Export → Model → OBJ. Export the OBJ with PNG textures and you're done!

NOTE: Even there are tracks from the BETA version of the game in the official release, the model will work, but there won't be any textures because of no .nsbtx file. You will have to use the textures from ripping out of the BETA version of the game, or just rip the course from the BETA version.

Creating Your Track

Now that you have exported your model, you should scale it correctly. Check out Recommended Scale for Retro Tracks for that. After that, you can proceed with making your own ported track! See the Importing Your Model section of the Modeling Tutorial next.

References

  1. This article, contributors to this article, creators of provided programs, and this Wiiki are not responsible for what happens to your computer while following these guides.
  2. Get the ROM and/or ISO image(s) by yourself. The Wiiki is not a piracy zone.