Talk:Custom Track Tutorial

From Custom Mario Kart
Jump to: navigation, search

Discuss here about the Custom Track Tutorial

Proposal: removing SZS Modifier from the main tutorial

I do not mean to diminish the importance of SZS Modifier here; the MKW hacking scene and community would never be what it is today without Chadderz and his research and tools. However, we all have to agree that it's an outdated and obsolete program which won't contribute much anymore to our scene. I suggest we get all of the information about the SZS Modifier, specially in pages like the KCL, KMP and Camera tutorials, take it away from them and put them in separate pages, like an "alternate" tutorial. This is so the information doesn't simply get erased, but it shouldn't be referenced on the main tutorial. I believe this will make the tutorials clearer and help the users make better tracks, but I want to know the opinion of the other Wiiki editors first, before doing those moves, as it would be a big change. What do you think? Igorseabra4 (talk) 04:46, 3 November 2016 (UTC)

While parts of the software are obsolete, I still use it. Believe it or not, SZS Modifier is crucial to the development of my .szs projects. -- banjo2


Which track do I replace?

How do I know which track to replace with my Custom Track? ~§ω★ξviL 22:44, 18 August 2012 (UTC)

It depends of used sound effects and more of the special features of the slots. -- Wiimm 07:54, 19 August 2012 (UTC)
Could that be a reson why my track freezes while it is loading? ~§ω★ξviL 23:25, 20 August 2012 (UTC)
May be. If you send me the track, I can make a quick preview for you. You can use a forums PM -- Wiimm 05:12, 21 August 2012 (UTC)


I think I'm gonna take the job of re-writing the KMP tutorial. I know a good way to write it ~igorseabra4

And why did you completely removed the PROGRAM tutorial page? Which aim is just to describe how programs work (ok kmp part wasn't good)
Vulcanus2 20:54, 19 March 2011 (CET)
I was going to re-write it in each tutorial's page. For example, using the SZS Modifier is so easy it doesn't require a tutorial, but the KMP editor does. So the tutorial for it is the same as the KMP editing ~igorseabra4
Much better than before, huh?
Igorseabra4 00:15, 21 March 2011 (CET)
Where can i find the download of SZS Explorer?!? I cant find it and i downloaded CTools!--Funkykong975 13:58, 4 August 2012 (UTC)
SZS Explorer is part of CTools. When you install CTools, you get SZS explorer. --Jefe 15:28, 4 August 2012 (UTC)
I still don't find it on my computer.--Funkykong975 06:13, 5 August 2012 (UTC)

Is there the possibility to make a Music Editing / Modification tutorial in here ? A lot of people find difficult the BRSTM making.

HelloImYourMind 01:17, 9 June 2011 (CEST)

You can start :P
Tock 02:04, 9 June 2011 (CEST)
Thanks! I'll start as soon as possible :) but I might need some help, I dunno this page format.
HelloImYourMind 02:09, 9 June 2011 (CEST)

Please! Update the tutorial, in the Kcl archives, when I put these values an error message appears:

"The KCL generation encoutered a problem with one or more areas. These have been excluded from the Kcl."
Type Variant Hex Value
Road (0x00) 002 0040

LBFlbf1 12:38, 3 July 2011

You can ignore this errors.
Tock 17:54, 3 July 2011 (CEST)
Thanks!
LBFlbf1, 18:27, 3 July 2011
I have other problem with kcl, my course model is too complex for the kcl, and I cannot expand the file. See a better description of the problem here.
LBFlbf1 13:12 4 August 2011

Unlock

Can this page be unlocked? I'd like a stab a cleaning up this page.--Jefe 20:01, 9 October 2011 (CEST)

It's only locked for unregistred people.
Tock 21:46, 9 October 2011 (CEST)

Ah. I misread the message at the top of the page then. --Jefe 00:57, 10 October 2011 (CEST)
Maybe it's the change you made to my user group, but this page is still locked for me. --Jefe 12:22, 15 October 2011 (CEST)
Now it must work :P
Tock 13:40, 16 October 2011 (CEST)

Shadows

I wanna make shadow on my CT, but i dony know how to make shadows. Could someone create a shadow tut?

PC Freak 17:06, 17 July 2012 (UTC)

There are so far four ways to create shadows for a course.
  • Vertex colors (requires a 3D editor that supports vertex colors and DAE exporting for BrawlBox)
  • Shadow mapping (requires a 3D editor that supports multiple uv maps and DAE exporting for BrawlBox)
  • Shadow polygon and texture blending
  • Darkened textures and/or polygons
They are listed in order of difficulty with the last option being the easiest in my opinion.
I'm not good at tutorial writing but maybe whoever writes it can explain each of these options for CT creators. --Torran 19:44, 17 July 2012 (UTC)
I'll do that last one first on a earlier version, if someone makes a tutorial I'll do the better one, becouse the characters don't get darker.
PC Freak 06:01, 18 July 2012 (UTC)

Need Help Importing Files

Hi guys, I'm new to your wiki and I like it a lot to be honest. I was directed here while trying to make a custom track. I have a problem when trying to import my obj file that I made in GoogleSketchup onto my brres editor. Every time I try to import my .obj file it says, "Importer Error, Invalid Argument vn.768448e-017-1.24703e-015-1. What do I do to fix this? I've heard that I need to use the OBJexporter because my sketchup is too new, but I don't know where to put it and how to use it to update. Help? Please? Sorry if this is in the wrong place or format, I'm still a noob on here.
-- Unsigned comment by Pokecole37 (talk)17:02, August 25, 2013‎ (UTC)

Your object exporter for Sketchup is overdated. You'll need to find an older version of the obj exporter. --Segatendo 8:04, 14 February 2014 (UTC)
Try this one.--Jefe (talk) 20:32, 14 February 2014 (UTC)

Saving a Track

Can someone please make a tutorial on how to save custom tracks and where to save them on the SD for Mario Kart Wii?--TAS EPIC (talk) 05:22, 2 August 2014 (UTC)

Read this. --Quajeek99 (a.k.a. ezioma3) (talk) 14:06, 2 August 2014 (UTC)

Custom Track will not load.

I followed all the instructions on the tutorial, but my custom track will not load when I try it on my wii.

--Yoshinator (talk) 00:25, 28 November 2014 (UTC)


There are so many causes for a track to not load. Have you tried removing objects from the KMP if there are any?
--Guilmon35249vr (talk) 02:14, 28 November 2014 (UTC)
Still does not load. Why is that?
--Yoshinator (talk) 23:14, 28 November 2014 (UTC)
What's inside your SZS file?
--Guilmon35249vr (talk) 17:01, 15 December 2014 (UTC)

Graphic bug in some of my custom tracks

I've already created some custom tracks on MKWII which worked fine but if i draw some complex shapes they'll look like this in the game: (left picture: mkwii / right picture: SketchUp)Superandi CTImportError.png

I used "SketchUp"(with obj exporter), "Wiimms SZS Tools" and "Wii Scrubber" for my custom tracks. Has anybody ever seen this bug and knows how to fix it?

--Superandi (talk) 22:06, 14 December 2014 (UTC)

I'd say it's mostly the complex geometry, more than the obj exporter can handle. I had something very similar happen to me when I attempted to export a minecraft mesh to another game. It also has to do with how it's constructed. Lots of indentations and curves, and very few simple flat faces aside from the floor. Models like this might look good inside SketchUp, and even if you managed to export it correctly, it is just too complex for a game like Mario Kart Wii. It would also look terrible because of how lighting works in MKWii - the mesh just "glows" so you don't get any shadowing and would appear to be mostly flat surfaces anyway. (Vertex coloring is used in standard tracks, and by some CT authors in levels like Sunset Ridge.)
Take a look at some of MKWii's stock tracks or even most custom tracks. Textures are used to approximate the look of complex surfaces, but the geometry itself is usually quite simple. Reoccurring shapes like those torches or columns should be constructed very simply or made into objects so they are instanced - a single object is loaded into memory once instead of a bunch of independent sections of a larger mesh. Once they are a certain distance away they are culled, further helping optimize the game - which can't happen if they are part of the main level mesh. Trees in stock tracks are a very good example of this - most are either objects or 2D flat textures applied to the main model. --Jefe (talk) 05:14, 15 December 2014 (UTC)
MDL0 files have a vertex limit of 65535, since there are two bytes for number of vertices (according to the MDL0 page).
Having more than that might cause problems like this, as it would write that number improperly, probably overwriting other data, or simply not writing the full amount of points.
As said above, try making textures to make these patterns on your wall.
--Guilmon35249vr (talk) 16:57, 15 December 2014 (UTC)
Thank you very much! The model had exceeded the limit (76692/65535). Converting torches and round pillars to separate objects helped a lot. The ornaments don't need as much vertices as round objects but I'll replace some of them with textures too.
--Superandi (talk) 21:11, 15 December 2014 (UTC)
Keep in mind that just because it runs now, doesn't mean that it will run well when the level is complete. Be sure to test it in split screen modes on a real Wii/Wii U right away. Even if it passes now, keep checking as you proceed. It's unfortunate that so many CTs are virtually unplayable in split screen modes. Note that most of those tracks with serious problems have similarly high-poly models.--Jefe (talk) 00:54, 16 December 2014 (UTC)

Solidity

the solidity tutorial is a bit unclear. it doesn't say what textures mean what when re-texturing the collision model. - littlelum

That's because it is entirely up to you. The main idea is that any surfaces that have specific properties (for example, the main road, off-road with dust, walls, boost panels) should share the same texture. So if you have 5 different texture you are using for your road surfaces, you should pick just one of them and apply it to all of those surfaces. This step isn't completely essential, but it will help simplify the model and improve performance under most circumstances. --Jefe (talk) 00:10, 7 January 2016 (UTC)

Music

How do I determine the backround music? -littlelum

Battles

How do you make a custom battle areana?--Littlelum (talk) 01:39, 15 January 2016 (UTC)

Using ROBLOX Studio to make tracks?

I would like to make custom tracks, but I find it very hard. But I noticed 'Roblox Studio' (which is a lot easier to make a track with) exports files to .obj files. And it also has 'smooth terrain', an easy-to-work-with tool, and seems great for creating a Mario Kart Track. But the problem is thatif I try to import it on SZS Modifier it either has an error or it loads but I can't play it. What can I do about it?--banjo2 (talk)

What does "it loads bug I can't play it" mean? Are your KCL and KMP correct? Does wszst give any error messages about the track? Leseratte (talk) 19:57, 5 May 2016 (UTC)
You could try to export/convert your obj to Collada DAE fileformate and then try importing it in BrawlBox. SZS Modifier isnt the best choice anymore. But honestly I have no idea and I never heared about that programm before.--Sucht93a (talk) 09:19, 6 May 2016 (UTC)
OK let me clear things up.

After I export my 3D model as Wavefront OBJ, I open up BRRES Editor and import the OBJ I just made. But the importer gives me this error in red text:

"Importer error Invalid argument v -57.7394 -4.76837e-007 153.512"

This only happens with SOME polygons SOMETIMES. It sometimes fixes the problem if I move the problematic object to another position or adjust it's size. If I open this same .obj with another modeling program such as anim8or or Blender, it imports with no errors. I am guessing BRRES Editor can't read coordinates such as

"-4.76837e-007"- particularly the "e-007" part.

Could there be a way to convert this kind of number to one that BRRES Editor can read?

(FYI, "Roblox Studio" is a program used to create 3D Online Multiplayer games. It has a export to .obj feature.) --banjo2 (talk)

When a number has scientific notation on it, it means it's a very minimal value which isn't supported by MKWii (it should be like -0.000000476837). If this happens, import your OBJ into 3DS Max or use FBXConverter so you can convert into a better format, and then re-convert into OBJ. --Atlas (talk) 21:15, 13 May 2016 (UTC)
I installed FBXConverter and converted my .obj to .fbx, but when I loaded it into BRRES Editor, the model was very distorted looked like the side faces of all the polygons were removed but not the top and bottom faces. I tried tinkering around with the settings on both programs, and the result was always the same. If I import then export my .obj with Anim8or, the result is exactly how I want it, but it merges all the polygons into one- which I don't want, especially for KCL. I know I can just move the decimal point to the left and add zeros, but I would have to do that roughly a few hundred times for each polygon in a regular-sized course, which would take hours on-end. There might be a converter just for this very problem, but it doesn't seem to exist yet.
Should I try going from .obj to .dae instead of FBX? --banjo2 (talk)
I found a way to "bypass" the scientific notation. Just open the .obj in notepad and Replace all "e-" with nothing, which removes all that unnecessary scientific notation.
I have tested some of these .obj's doing this, and it looks exactly the same as it does in the 3D editor. I guess removing some extra zeroes from the coordinates doesn't actually make any noticable difference in the resulting model. Thanks anyway! --banjo2 (talk)
wkclt can read an obj and reexport the data as object. It never use scientific notation. But I'm not sure, if all needed aspects of an obj are handled, because it was developed for KCL import. Also the number of faces is limited to 65535.
A possible command: wkclt decode source.obj -d dest.obj
-- Wiimm (talk) 21:45, 24 May 2016 (UTC)

Idea for Wiimms Tools

Would it help if I implement a command/tool, that scans an object file and copy all lines 1:1 with exception of "v" lines. v-lines are scanned for numbers and printed in a user defined format, default "%3.1f" for floats and "%d" for ints.

-- Wiimm (talk) 12:35, 25 May 2016 (UTC)

Problems w/ Tools

OK, so I want to make custom tracks, but every tool I download (besides KMP Cloud) has a different problem:

-SZS Tools: I'm asked with which program I want to open it with, and I'm afraid the wrong tool will make it crash...

-CTools: It was thought to be malicious and wasn't downloaded. (It was technically my decision, it said it was and I decided to cancel it. :P)

-KMP Modifier: Windows SmartScreen "protects" against CTools Connection and KMP Modifier.

I have Windows 10, if that helps. --PollaxDragon (talk) 13:56, 20 November 2016 (UTC)

So:
  • Wiimms SZS Tools: you don't really "open" the program (unless you're using the GUI), you just install it and after rebooting you can use the commands
  • CTools: if you're downloading from the offical site there's no need to worry about malicious content.
  • KMP Modifier: there's no need for two different kmp editors (you already have Cloud), but if you wanna have it, if it's requesting a connection, I believe that there's no problem if you don't allow it, as the connection's probably to check for updates and none of these programs are updated anymore
--Igorseabra4 (talk) 05:18, 22 November 2016 (UTC)
It says CTool's signature is invalid, and it won't let me open the folder... what do I do? --PollaxDragon (talk) 17:30, 23 November 2016 (UTC)
Try re-downloading it. If it still doesn't work, then I don't know how to help you... maybe you should google the message it displays.
--Igorseabra4 (talk) 17:45, 23 November 2016 (UTC)

I need Wiimms SZS tools and how di I install it? (I tried restarting the computer but it doesn't do anything) I have windows 10--Littlelum (talk) 20:46, 22 March 2017 (UTC)

Anyone?--Littlelum (talk) 23:27, 10 July 2017 (UTC)

Texture size

I have photo shop and it asks me what size the image should be so what size and what units should it be?--Littlelum (talk) 02:47, 20 March 2017 (UTC)

Plugin Problem

I found a link on this wiki for an OBJ-importer for sketchup but it doesn't work!--Littlelum (talk) 03:26, 17 July 2017 (UTC)

bress problem

How would I move a bress INTO an szs file?--Littlelum (talk) 04:03, 17 July 2017 (UTC)

Using CTools SZS Tool. YoshiGo99 (talk) 01:47, 18 July 2017 (UTC)

Strange Crashing

Upon testing my track in CTGP-R, it always crashes on load. I have all the minimum files, and no objects in the KMP. I have one camera, whish settings are: Type: 1 Next: FF Route: FF Viewstart: 10884.82 (about) Time: 294

Can anybody help me?--Littlelum (talk) 22:20, 6 May 2018 (UTC)

Have you tried using Wiimms SZS Tools to see what your problem is? --KantoEpic (talk) 22:42, 6 May 2018 (UTC)
Ok, I used the SZS check output feature on Wiimms tool manager (the GUI) and I got this:
CHECK YAZ0.U8:/cygdrive/c/Users/littl/Documents/myrace.szs
* CHECK KCL:/cygdrive/c/Users/littl/Documents/myrace.szs/course.kcl
* CHECK KMP:/cygdrive/c/Users/littl/Documents/myrace.szs/course.kmp
  > All indices are zero based!
  > Section CAME, Camera #0 of 1, type 'opening camera'
    + WARNING: Opening camera type should be 4 or 5, but not 1.
  > Section CAME
    + WARNING: Missing a camera with type 0.
  > Section ENPT
    + WARNING: Point #0 is outside of all convex check quadrilaterals (pos bug?).
  > Section ITPT
    + WARNING: Point #0 is outside of all convex check quadrilaterals (pos bug?).
  > Section CKPT
    + WARNING: Check points #0 and #0 are to near together (0.000) (pos bug?).
    + WARNING: No check point with mode 0 (lap counter).
  > Section POTI
    - HINT: Route #0 of 1 not used/linked.
* CHECK YAZ0.U8:/cygdrive/c/Users/littl/Documents/myrace.szs
    + WARNING: Missing file: ./itembox.brres
    + WARNING: Missing file: ./posteffect/posteffect.bblm
    + WARNING: Missing file: ./posteffect/posteffect.bdof
 => 9 warnings and 1 hint for YAZ0.U8:/cygdrive/c/Users/littl/Documents/myrace.szs

Could you tell me what it means?--Littlelum (talk) 18:11, 19 June 2018 (UTC)

You need to use KMP Cloud to set the first opening camera's ID to that of a camera with type 5. You have item boxes, so you'll need itembox.brres. Ignore the warnings about the missing posteffects; those files aren't actually necessary. --Cotni (talk|contribs) 18:46, 19 June 2018 (UTC)
I removed the item box stuff in the KMP, and set the camera to 5, but it still crashes. I got this in Wiimms tools:
CHECK YAZ0.U8:/cygdrive/c/Users/littl/Documents/myrace.szs
* CHECK KCL:/cygdrive/c/Users/littl/Documents/myrace.szs/course.kcl
* CHECK KMP:/cygdrive/c/Users/littl/Documents/myrace.szs/course.kmp
  > All indices are zero based!
  > Section ENPT
    + WARNING: Point #0 is outside of all convex check quadrilaterals (pos bug?).
  > Section ITPT
    + WARNING: Point #0 is outside of all convex check quadrilaterals (pos bug?).
  > Section CKPT
    + WARNING: Check points #0 and #0 are to near together (0.000) (pos bug?).
    + WARNING: No check point with mode 0 (lap counter).
  > Section POTI, Route #0 of 1
    - HINT: CAME route: 1 route point of 2-1 with zero speed.
* CHECK YAZ0.U8:/cygdrive/c/Users/littl/Documents/myrace.szs
    + WARNING: Missing file: ./posteffect/posteffect.bblm
    + WARNING: Missing file: ./posteffect/posteffect.bdof
 => 6 warnings and 1 hint for YAZ0.U8:/cygdrive/c/Users/littl/Documents/myrace.szs

Is there anything else that I need to do? If it helps, I'm trying to test it in time trials, using CTGP-R.--Littlelum (talk) 23:52, 27 June 2018 (UTC)

Ok, so from what I read in the wiki, I need to set enemy routes and checkpoints, but places on the wiki says they are not required to run on time trials. The only thing I don't understand is the route related error, which is the route that the camera uses. Am I making a good guess?--Littlelum (talk) 04:26, 29 June 2018 (UTC)?
You definitely need some checkpoints. How else should the game know where the finish line is and when you completed a lap? Enemy routes should not be required for time trials. The Route error means you have a point in your route with a speed of 0. That is just a hint and should not cause any crashing. Plus, apparently two of the posteffect files are missing. -- Leseratte (talk) 04:54, 29 June 2018 (UTC)
Thanks! It doesn't crash anymore, but the lap doesn't count, so I tried to debug it. This is what I got:
CHECK KMP:/cygdrive/c/Users/littl/Documents/course.kmp
  > All indices are zero based!
  > Section CKPT
    + WARNING: Check points #3 and #4 do not form a convex quadrilateral (pos bug?).
    + WARNING: Check points #4 and #5 do not form a convex quadrilateral (pos bug?).
    + WARNING: Check points #8 and #9 do not form a convex quadrilateral (pos bug?).
    + WARNING: Check points #9 and #10 do not form a convex quadrilateral (pos bug?).
  > Section POTI, Route #0 of 1
    - HINT: CAME route: 1 route point of 2-1 with zero speed.
 => 4 warnings and 1 hint for KMP:
 => see http://szs.wiimm.de/cmd/wkmpt/check#desc for more info.

Could you tell me what that means? I couldn't make sense of it--Littlelum (talk) 21:54, 29 June 2018 (UTC)

There are many reasons why a lap may not count. It's either caused by the lack of key checkpoints (or there are zero), checkpoints that are hard to reach or your checkpoints are too small. The actual warnings for the checkpoints not forming a quadrilateral aren't as important. --KantoEpic (talk) 22:19, 29 June 2018 (UTC)
Got it! I fixed the warnings about the quadrilaterals and everything worked! Thanks everyone!--Littlelum (talk) 22:52, 29 June 2018 (UTC)

Uh oh. I lowered the walls and shrunk some textures (in sketchup) and then it crashed. I tried debugging it in wiimms tools but nothing came up (except the post effects stuff)--Littlelum (talk) 00:12, 10 July 2018 (UTC)

Custom track not loading on Wii

I made a track to use as a custom track. It loads and plays fine on dolphin, but when I load it to my usbloader (which I use, and have always used to get games on the Wii), it crashes to a black screen.

I got to tinkering and found that whenever I modify anything at all (like moving the start location on Luigi circuit a couple of units right), the Wii crashes. Again, dolphin loads the track fine. Any ideas on how to fix this?

Edit: I got my track to work. I made a fresh copy, changed the game id using partition.bin changer to create a new save, and imported my track.

Making new BRRESS crashes course

I had a track that worked perfectly. After making a new course_model.BRRESS it crashed. (The only difference was the lower walls and scaled-down textures) Does anybody know why that happened?--Littlelum (talk) 02:56, 31 August 2018 (UTC)