User:Baoulettes/Creating a Custom Character in 3ds Max

From Custom Mario Kart
Jump to: navigation, search


Hello.
I will try to explain you: How to make a custom char for Mario kart Wii (Non animated.)
You will need :
-3DS Max 2009 (or Highter)
-Ctools Library made by Chadderz
-SZS Modifier
-.SZS of the target Kart/Bike
-Gimp (or other PNG files editor that keep Alpha channel.)
-A character I mean a ready for Max (this step will be light)
- Little knowledge on 3DS max.
-A Driver_Model.brres already fixed by me (KART ONLY!)[1]
-A Driver_Model.brres already fixed by me (BIKE ONLY!!)[2]
_______________________________________________________________________________________________________________
Optionnal:

-Celebi Source files (mean all OBJ, png, ect)[3]
_______________________________________________________________________________________________________________

First, this tutorial made with "Celebi on Bullet Bike" some things / name will change for other Kart so please don't be ignorant just read and understand that tutorial and you will be able to make EVERY character on Every Bike/kart you want.

Okay, here we start:
First, we will extract the bike for 3DS Max.
Open your Kart/bike .szs on SZS modifier.
Go to "Kart_Model.brres"
Then in folder 3DModels(NW4R)
Click on "body" (body.mdl0)

[4]
Then at this part click on files then Export
and place it somewhere you can find it.

[5]
Now we will need the texture of the bike/kart.
So go to the same .szs and same BRRES (Kart_Model.brres)
but go in Texture(NW4R) Folder
Then, click on the texture are on the entire bike/kart
the usually like "xx_bike_all or xx_kart_all
and then when you see it double click and the Image

[6]
Now, export the texture as you did for mesh,
'File-> Export'
and place it with the OBJ (don't start to make a mess hum)

[7]
Now we're gonna fix the OBJ for 3DS Max (if you import as it you will loss EVERY UV map.) so let open "body.obj" (for me but if you follow the tutorial you probably know that are the OBJ to be opened right?) Open it with WordPad.
and then go to: Replace
then replace every "," (Virgules)
as a "." (Dots)
and click Replace all.

[8]
Once it's done, save the files.
Now, we're gonna fix the PNG for 3DS Max UV map. (we don't use 4x repetitive texture mapping.)
Open the .png with an Image Editor (like Gimp)
and simply put it as I did.

[9]
After you did like me, just save the PNG (make backup if needed).

New we're to do 3DS MAX, so import your Kart (File (icon 3ds max)) Import and select your Body.obj
now that should look like it.

[10]
As you can see there some problem, no texture and weird appearence, but don't worry it easly fixable!
First, do "Normal" and tick "Flip Normals"

[11]
And, now as you can see, that still look glitchy, but fix it by doing:
"Edit Normals"
Then, click on the scene
do: "CTRL + A" to select all the normals
and click on "Unify".

[12]
Now, let add the texture on,
so do: "Edit Mesh"
and now
Just drag and drop the texture on the polygone (on all polygone!)

[13]
Now, as you can see, there still glitchy!
We just have to do UV mapping 4 time smaller.
for that do
"Unwrap UVW",
select all part you see on the small windows and make them 4 time smaller.
(right Click and Freeform Scale is the best tool for it , I think.)

[14]
And, after that, just make it 4 time smaller and Flip it Verticatly.

[15]
Now, check your mesh by doing "Edit Mesh" and look around.

[16]
Now, you need a character.
Import it (File (icon 3ds max) Import and choise your character.
now your character should be imported but it doesn't fit.

[17]
Now you have to pose it one the vehicle (sorry I can't really explain it because that would take me month to make every step just search for Basic - 3DS max tutorial on how to rotate , move vertex or bones if your mesh have it)
Once posed, it should look like it .

[18]
Now that you get it.
Export it as OBJ !(file (3ds max icon) Export)
with that parameter.

[19]
Once that done make a copy of every texture files you got (generaly no more than 4 body bike, ect) and open them in Gimp and Flip/Mirror them verticatly.
(does it really need a screen?)

Once that done open your SZS with Ctool library.
and export the "Kart_model.brres"

[20]
Once export open the "Kart_model.brres" with Brres Editor.
(Leave Ctool with the szs opened)
Once opened Don't TOUCH anything!
Just go to "Tools -> Options" and change "Renderer Directx 9.0C" to "Renderer Directx9.0C (Shaderless)" (it's the second choise) Once that done, just click OK.

Now! Select "body" You will see at the right the mesh of the bike Alone.
Right click on "body" and "Delete"
You should get it like that

[21]
Now, we will import your Model.
Simply click on "File -> Import -> WaveFront OBJ"
Now, follow the screen:

[22]
Once that done click "Import"
and by clicking on the last "mld0" (your .OBJ file name)
You should see it like it. (yes that Glitchy AGAIN!), but don't worry, easily fixable.

[23]
Now, we're gonna renamme the MDL0 so the game will be able to read it.
Simply, right click on your file name mdl0 and rename it as "body" and NOT "Body" or anything else!

[24]
When done, we're gonna import every fliped/mirrored texture on the BRRES to fix the glitch.
so click on the TEX0 of your texture (material name) and replace them with fliped/mirrored texture.

[25]
Once that done on every of YOUR texture not nintendo one. check the result.

[26]
It should look fine now we're gonna fix the Drive (old one) over your mesh and make glitch if unwanted.
So go back to Ctool Library and Export "Drive_model.brres" as you did with "Kart_model.brres"
____________________________________________________________
Following Step not needed if you download my own Driver_Model.brres
____________________________________________________________
And open "Driver_model.brres" with SZS modifier,
click on 3DModels(NW4R) and click on first MDL0
and Click on Pinch tools
Like that screen:

[27]
Now, grab the mesh in a sort of make it unviewable (as we can't delete the mdl0 because the game will freeze and we can't change it so we use a little workaround)
And finally, the end you should get something like that:

[28]
When do save the mdl0 and close (File Save)
And don't forget to save the BRRES before closing SZS Modifier.
____________________________________________________________
Previous Step not needed if you download my own Driver_Model.brres
____________________________________________________________
Once that done, go back on Ctool Library.
and Right click on Driver_model.brres and replace,
And browse your Driver_model.brres and click Replace.
Then Select "Kart_Model.brres" and right click replace and browse to your own Kart_model.brres.
Now do CTRL+S copy your SZS on SD - My Stuff Folder if you use Riivolution,
or use WiiScrubber
Go to "MKWISO\Race\Kart" and replace your base bike with your .szs and go test in game!

[29]
Hope you understand it. And enjoy your mod! Baoulettes.

Download Link= http://www.mediafire.com/?o4fy9nj3l62wwj2 Celebi on Bullet Bike