Talk:Love Circuit (FunkyDude15)

From Custom Mario Kart
(Redirected from Talk:Love Circuit)
Jump to: navigation, search

Critics v1

I like the track, but the short cuts are to powerful. A normal round takes about 20 sec, but with a golden mushroom it is possible to use all 3 short cuts and to finish the round in about 10 seconds. Another point are the itemboxes at the peak of the hart. Only the first player get a good placed itembox, all other goes offroad.

Wiimm (talk) 06:54, 30 May 2013 (UTC)

Im not sure if you know, but I'm working on version 2, and the shortcuts will be gone, and the corner cut at the end will be save less time. Plus, I scaled it up. So I won't have to make it five laps :Wink: :Wink: Ill also change the spot of the item boxes. If you have any other questions let me know or add me on Skype. --FunkyDude15 (talk) 23:19, 31 May 2013 (UTC)

Critics/Ideas v2

  • The wigglers are to fast, maybe also the penguins.
  • Replace the penguins by ducks (see Psyduck Cliffs).
  • The left handed ramp before the mushrooms has a wring position and direction.
  • The respawn point before the mushrooms is to near and between the ramps. Find a place, where the drivers can use both ramps, and at least one ramp with a starting boost.

Wiimm (talk) 23:06, 8 June 2013 (UTC)

That's for the feedback, I'll fix the bugs and try your ideas. --FunkyDude15 (talk) 03:39, 9 June 2013 (UTC)
All my ideas are now realized :)
But now I think, the dugs are a little bit to lazy (slow).
Wiimm (talk) 18:58, 20 June 2013 (UTC)
There is no obligation to to all what I say (faster dugs). See some comments only as private opinion.
Wiimm (talk) 21:43, 20 June 2013 (UTC)

Media

RemyInTheSky was it really necessary to remove my video for v1 just for yours? --Soarin MKWII (talk) 20:23, 16 June 2013 (UTC)

That was me that did that. Sorry. --FunkyDude15 (talk) 22:08, 16 June 2013 (UTC)

Bugs in v2.2

Bullet Bill don't fly over the mushrooms.
Solution: Adjust the height of the item points and use the correct ITPT Settings
Wiimm (talk) 06:23, 5 July 2013 (UTC)
We had 2 freezes for 2 tries while playing online with 6 players.
Wiimm (talk) 19:16, 21 August 2013 (UTC)
What was the freeze from? Was it from the BB or did it not load.... I need more info.--From FunkyDude (talk) 00:12, 22 August 2013 (UTC)
video -- Wiimm (talk) 09:52, 23 August 2013 (UTC)
Hm. I honestly dont know what's causing that, but I know it's not the Bullet. Do you have an idea of what's causing it? If you do, let me know. --From FunkyDude (talk) 13:24, 25 August 2013 (UTC)
For our next test series I put in in the distrib again, but on another slot. And I advise the others to use other characters to exclude interferences with CT characters.
Wiimm (talk) 13:30, 25 August 2013 (UTC)

poihana freeze

Summary
The track only freeze at slot 5.1 (online and offline) and freeze always, when the poihana becomes visible. But 5.1. is the home slot for poihana (peach beach). We have tested v2.2 it on 1.1, 8.3 and 8.4 without freeze, and v1.0 on slot 3.3 and v2.0 on 5.2 before.
My first guess is, that poihana are the problems. So I compared the settings and found, that you have 1 poihana with setting-1 == 0, but this value is not used by Nintendo. Further tests are needed.
Wiimm (talk) 20:43, 27 August 2013 (UTC)

Now I have removed the poihana and played the track on slot 5.1 without freeze or other problems. It must be the settings.
Wiimm (talk) 21:19, 27 August 2013 (UTC)
It was meant to be in Slot 5.3 in the first place, but put it in the slot of your choice. I give you permission to update it if it's nessesary.
--From FunkyDude (talk) 23:13, 28 August 2013 (UTC)

Does it work on Slot 5.1 if you put Psea in too? I haven't tested this Object personally, but some experience with Volcano Beach 3 reminded me of this.
-- Have a nice day, from ZillaSpaz 16:02, 29 August 2013 (UTC)

It hasn't been tested with Psea yet, I will try that out. Thanks :D --From FunkyDude (talk) 16:23, 29 August 2013 (UTC)
Some interesting note:
For any reasons, Volcano Beach 3 v1 use also slot 5.1 in my coming distribution. And it has the same freeze when the poihana becomes visible.
Wiimm (talk) 21:49, 8 October 2013 (UTC)
Very interesting. This may be good for testing because it seems like were gaining more info on this slot. --From FunkyDude (talk) 00:03, 9 October 2013 (UTC)

v3

zip file comes with a crc error. Please re-upload it again. -- Wiimm (talk) 21:10, 16 November 2013 (UTC)

What exactly does that mean? --From FunkyDude (talk) 14:02, 17 November 2013 (UTC)
The internal CRC checksum of the SZS file differs from the stored one ⇒ the zip file is damaged and invalid.
Re-uploading may fix this.
Wiimm (talk) 15:36, 17 November 2013 (UTC)
The new zip is ok -- Wiimm (talk) 15:40, 17 November 2013 (UTC)
Yes, I got some friends to test it before I uploaded it. --From FunkyDude (talk) 15:43, 17 November 2013 (UTC)

Critics/Ideas v3

  1. 2 Mushrooms:
    1. Move them to the left into the racing line.
    2. Lower the first mushroom, because if small or playing with some karts you have no chance to hit the top of the mushroom.
  2. Position of minimap is wrong
  3. Last driver starts in offroad

The last 2 errors can be fixed with:

wszst patch TRACK.szs -od NEW_TRACK.szs --minimap --kmp narrow,left

Wiimm (talk) 13:07, 18 November 2013 (UTC)

I was aware of those bugs but never knew your tools could fix them. Thanks a lot! --From FunkyDude (talk) 13:49, 18 November 2013 (UTC)
You can use these options also with the commands CREATE and NORMALIZE and some others.
Using wszst minimap --auto FILE will center the minimap too. In this command FILE can be a SZS, BRRES or MDL file.
If the minimap is to large, just scale it with --scale factor.
Wiimm (talk) 13:59, 18 November 2013 (UTC)
Yes, I knew about the wszst minimap --auto FILE command, but it just slipped my mind before releasing. Your tools really are amazing! --From FunkyDude (talk) 14:10, 18 November 2013 (UTC)
Bug:: I found a hidden boost pad before the short cut in the city. It allows to use the short cut with full speed.
Wiimm (talk) 17:23, 24 November 2013 (UTC)
How can I fix that? --From FunkyDude (talk) 17:50, 24 November 2013 (UTC)
I think it is an artefact of KCL creating. It seems, that remaking the KCL with wkclt encode course.kcl --kcl drop,rm-facedown or with wszst patch track.szs --kcl drop,rm-facedown (my usual KCL remaking commands) help (I can't see the boost in 3DS max). I will test the modified track later.
Wiimm (talk) 20:15, 24 November 2013 (UTC)
My test failed, but here is a video about the bug: video
Wiimm (talk) 21:48, 24 November 2013 (UTC)
Perhaps I found it. See this picture
It's a 3DS max view of the KCL, but only walls and boosts are visible. Then I have removed the first boost pad. In the red circle you can see 3 blue points. This are vertices of a very thin face; maybe all point are on a line. And if making the line longer, it comes to the point were the bug appears.
Wiimm (talk) 22:05, 24 November 2013 (UTC)