Creating a Minimap with SZS Modifier

From Custom Mario Kart
Jump to: navigation, search

This guide is presented as several steps with alternate approaches; choose the methods that work for you.

Minimap Creation

Step 1: Creating a Minimap Model

You should be using either one texture or a few different textures exclusively for roads in your model. If not, edit your model or create a collision model so that they are; road textures in the wrong places can lead to glitches such as driving up vertical walls and unintentional shortcuts. If you want to display some shortcut paths that share textures with other parts of your model or include other "landmark" features to help with positioning objects, paths and checkpoints in your KMP, you will need to make a separate minimap model. These positioning landmarks should be removed when you release your level.

The SketchUp method is recommended for creating a minimap with landmarks or a minimap with reduced complexity.

  • SketchUp
Road surfaces selected in SketchUp, then pasted into a new file.
Select one instance of each texture used on your roads, then from the right click menu choose Select > All with same Material, then Copy. Next go to File > New. Select Paste In Place from the Edit Menu. If you are creating a map model with landmarks, you can select the surfaces you want to add and paste them into your model the same way. If you haven't already, select your entire model, right click, and then explode all components and convert all curves to polygons. Next, delete any lines separating textures or holes in your map model to reduce the number of polygons. Save as a new SketchUp file, then export as an OBJ file.
  • SZS Modifier
Roads selected in SZS Modifier. Notice that SZS Modifier mirrors the perspective in this view. This will not affect your level in any way.
Load your SZS in SZS Modifier. Click on the course_model for your level, which will open up a new window displaying your model. Zoom in once the textures have finished loading. Look at the right-hand pane. It displays all the of textures used in your model. Holding the CTRL button, select only the textures used on your roads. Next choose Export from the File Menu and save as an OBJ file.

Step 2: Importing the Minimap Model

A minimap with landmarks, viewed from the KMP Editor of SZS Modifier. The thin white lines are low barrier walls in the level. Using landmarks, you can place objects near, on top of, or behind the barriers with precision.

In the previous tutorials, we used the BRRES Editor to import our course model. While the BRRES can create a map model, the minimap will usually not be displayed under the player icons in the correct positions. Additionally, trying scale and position a BRRES Editor-imported minimap will also fail to maintain the correct position on the screen relative to the player icons. So even if the minimap does line up, it usually won't be the right size and it will be difficult to adjust. SZS Modifier will position the minimap correctly. However, SZS Modifier can't expand files, so your minimap is required to be fairly simple.

It is recommended to use the BRRES Editor when importing a minimap model with landmarks for KMP editing. Use SZS Modifier to import a simpler minimap model for when you release the level.

  • BRRES Editor
Using the same procedure as when you imported your course model, import the OBJ file you created in Step 1. Click on the Map Model checkbox instead of Course Model, then click Import.
  • SZS Modifier
First you will need a minimap BRRES file from a large level that contains a lot of vertex space, such as Mushroom Gorge. Open the map_model.brres file with SZS Modifier. Select Import from the File Menu. When prompted to disable culling, choose Yes. Import the OBJ file you created in Step 1. If the model was imported successfully, your model will now be visible in the window.Save the file.
If it was unsuccessful, you will see an error message that says: The model is too complex to fit in the selected polygons. Select more polygons or reduce the model complexity. You will need to go back to Step 1 and simplify your map model.

Step 3: Finding Minimap Position Values

The next step is to find the position values for the view region of your minimap. These values can be approximate; larger numbers will make the view region larger and the minimap smaller. Skip to step 5 if you did not use SZS Modifier to create your map model file in Step 2. Skip to step 4, if you use Wiimms SZS Tools to find automatically good positions.

  • SketchUp
Measure in meters from origin (where the red, green and blue axes meet) a bit farther than the farthest edge of your drivable roads in each direction. Write down these values and label them Left, Down, Right and Up, in that order. Make the Left and Up values negative, assuming origin is near the center of your model. If you're not sure which direction is which, go to View > Toolbars > Views and activate the Views Toolbar. Click on the house icon labeled Top. This will orient your perspective so that the top of the screen is Up, etc.
  • BRRES Editor/SZS Modifier
Go back to Step 2 and create a map model file using the BRRES Editor, even though you used the SZS Modifier technique in that step. Open that map model file with SZS Modifier, go to Tools -> Minimap Control and write down the settings.

Step 4: Positioning the Minimap

The Minimap Control interface in SZS Modifier.
  • SZS Modifier
Open the map model you created with SZS Modifier in Step 2, go to Tools -> Minimap Control and enter the values you found in Step 3.

Step 5: Importing to Your Level

Finally, use SZS Explorer to import your new map_model.brres file into your level's SZS.
Test it in-game once you have your player start positioned to see if the minimap is positioned and scaled acceptably.