Difference between revisions of "Talk:SMS Delfino Plaza"

From Custom Mario Kart
Jump to: navigation, search
(Texture Problem)
(Texture Problem)
Line 97: Line 97:
 
Could I get some help for the textures of this course? I can't seem to figure out what could possibly be wrong. In the model for Sketchup, everything appears normal. But when I import it to the SZS file, it ends up looking bad. I have checked the faces and they are being used by textures, but the texture doesn't show up. Is there a tool that could automatically fix it? The model can be found here: http://www.mediafire.com/?16i7m009zh3j1ow. Thank you so much! --[[User:Bcphoton|Bcphoton]] ([[User talk:Bcphoton|talk]]) 05:31, 20 April 2013 (UTC)
 
Could I get some help for the textures of this course? I can't seem to figure out what could possibly be wrong. In the model for Sketchup, everything appears normal. But when I import it to the SZS file, it ends up looking bad. I have checked the faces and they are being used by textures, but the texture doesn't show up. Is there a tool that could automatically fix it? The model can be found here: http://www.mediafire.com/?16i7m009zh3j1ow. Thank you so much! --[[User:Bcphoton|Bcphoton]] ([[User talk:Bcphoton|talk]]) 05:31, 20 April 2013 (UTC)
  
Is there any way to import the model with the SZS Modifier or Wiimms SZS Tools? --[[User:Bcphoton|Bcphoton]] ([[User talk:Bcphoton|talk]]) 21:05, 24 April 2013 (UTC)
+
 
 +
Is there any way to import the model with the SZS Modifier or Wiimms SZS Tools? I just wonder if that would help the texture problem. --[[User:Bcphoton|Bcphoton]] ([[User talk:Bcphoton|talk]]) 21:05, 24 April 2013 (UTC)

Revision as of 21:52, 4 May 2013

Author needs help

I (Bcphoton) have made it very far with this track, but I can't get it to work. If I could get help or if someone would finish the file so it will work and then send it to me, that would be much appreciated. Email me a bcphoton@yahoo.com.

So it's only an ALPHA release? Why giving it the version number 1.0? Please read "Version Number".
Wiimm 08:58, 23 February 2013 (UTC)

Could I send this to someone who would finish it for me? --Bcphoton 23:46, 26 February 2013 (UTC)

Is there any easier way to do this track? Because no matter how hard I try, I just can't get this working right. --Bcphoton (talk) 03:00, 16 April 2013 (UTC)
No, not really. Does this mean you're quitting? I'd be happy to take the page off your hands, since I'm working on my own SMS Delfino Plaza as well.
ZillaSpaz (talk) 18:49, 16 April 2013 (UTC)
I think I will try to get it finished, but if I get to a point where I can't make any more progress, I will hand it over to you. --Bcphoton (talk) 03:10, 17 April 2013 (UTC)
Also, where did you get the model for this course? If it is possible, I would eventually make a battle course for Gelato Beach, but I cant find a model for it. --Bcphoton (talk) 03:18, 17 April 2013 (UTC)
Someone gave me the model, but I'm going to start over.
ZillaSpaz (talk) 05:19, 17 April 2013 (UTC)

Bug Report

This may help to find the bugs:

CHECK YAZ0.U8:tracks/_income/SMS Delfino Plaza v1 (BCphoton).szs
* CHECK KCL:tracks/_income/SMS Delfino Plaza v1 (BCphoton).szs/course.kcl
    - HINT: 3837 of 8378 drivable triangles are face down => --kcl=RM-FACEDOWN
    - HINT: 3384 of 8378 drivable triangles are face down (>30°).
    - HINT: 70 of 10864 triangles had extreme values => --kcl=DROP-FIXED
    + WARNING: 487 of 10864 triangles have invalid values => --kcl=DROP-INVALID
* CHECK KMP:tracks/_income/SMS Delfino Plaza v1 (BCphoton).szs/course.kmp
  > All indices are zero based!
  > Section CAME, Camera #0 of 1, type 'opening camera'
    + WARNING: Opening camera type should be 4 or 5, but not 0.
  > Section CKPTl
    + WARNING: No check point with mode 0 (lap counter).
  > Section JGPT
    - HINT: Respawn point #1 of 7 'j1' not used/linked.
    - HINT: Respawn point #2 of 7 'j2' not used/linked.
    - HINT: Respawn point #3 of 7 'j3' not used/linked.
    - HINT: Respawn point #4 of 7 'j4' not used/linked.
    - HINT: Respawn point #5 of 7 'j5' not used/linked.
    - HINT: Respawn point #6 of 7 'j6' not used/linked.
  > Section POTI
    - HINT: Route #0 of 1 not used/linked.
* CHECK YAZ0.U8:tracks/_income/SMS Delfino Plaza v1 (BCphoton).szs
    - HINT: Unknown file:    ./course_collision_model.brres
    + WARNING: Missing file: ./itembox.brres
    + WARNING: Missing file: ./posteffect/posteffect.bblm
    + WARNING: Missing file: ./posteffect/posteffect.bdof
    + WARNING: Missing file: ./vrcorn_model.brres
 => 7 warnings and 11 hints for YAZ0.U8:tracks/_income/SMS Delfino Plaza v1 (BCphoton).szs

Wiimm 01:31, February 25, 2013 (UTC)

Thank you so much! How did you get this?
-BCphoton
The report was done with Wiimms SZS Tools, command: wszst check track.szs
Wiimm 16:55, 25 February 2013 (UTC)

Model

You're using this model from the 3D warehouse, correct? Although the model was uploaded anonymously, you MUST NOT take credit for the model. You need to post a link to the model you used in your article. Also, please sign your talk page posts with four tildes (~~~~) to automatically generate your signature with the time and date.

Looking at your SZS and that SketchUp file, I see where some of the problems are. First, about half of the faces of the model are facing the wrong way, this is corroborated by Wiimm's analysis showing face down triangles. Those 'blue' faces need to be reversed. Second, you must select the whole model and explode all components before exporting. You'll need to do this several times because there are a lot of components.

Basically, you took this model from the warehouse and tried to convert it without trying (or knowing) to fix it properly. I really hope you weren't going to claim it was entirely your own work. --Jefe 16:23, 25 February 2013 (UTC)

No, I wasn't going to claim that I designed the model at all (except for my additions to it.) Where and how should I give credit? Should I put them in the designer spot on this page? --Bcphoton 22:47, 25 February 2013 (UTC)
The designer of this track is Nintendo. Mention how you obtained the model and add the link in the overview section.--Jefe 22:51, 25 February 2013 (UTC)

KMP Problems

My KMP isn't lining up with my minimap at all. What can I do to fix it? It makes it so I start way far away from the track and keep falling into blackness. --Bcphoton 02:46, 26 February 2013 (UTC)

You need to determine the height of your course and make sure the course is above origin. You can do this in Sketchup by measuring from origin on either of the horizontal axes to the height of your level or you can try MagicY to set objects automatically. Personally, I'd suggest trying to finish your other track (or maybe start a new one from scratch) first before attempting this model. This Sketchup model has a lot of issues and in my opinion is kind of a nightmare to fix, especially the texturing after you fix the faces that are wrong. Finishing another track first will give you some much-needed experience and will teach you the modeling techniques needed for MKWii. --Jefe 22:52, 26 February 2013 (UTC)

Texturing

Is there any way in Sketchup to reverse thr faces of an object but not reverse the texture? --Bcphoton (talk) 12:24, 15 March 2013 (UTC)

It's possible there's a plugin that will do that, but as far as I know, no. --Jefe (talk) 12:11, 19 March 2013 (UTC)

Moving Model

How can I move the model, collision model, and minimap all the same distance? I don't want to remake them each time I move the course. --Bcphoton (talk) 03:47, 19 March 2013 (UTC)

You really shouldn't be moving the course, since you also have to change your KMP. Moving the same distance in SketchUp is fairly easy. As you're moving, note that you can sometimes see the line dashed blue, red or green. That means you're moving it straight along an axis. While it's colored, type in the distance you want to move. Then repeat the process on your other models. You can also move the origin (align axes while right clicking a surface) to a certain spot on each model, but that's a bit less reliable in my opinion. --Jefe (talk) 12:11, 19 March 2013 (UTC)

Texture Problem

Some textures appear as a plain color, and some dont appear at all. I checked and they are all white faces in Sketchup and the textures are all powers of 2. How can this be fixed?--Bcphoton (talk) 16:22, 22 March 2013 (UTC)

If solid colors are being replaced by black, it's because it isn't actually set to use a texture. You'll need to check in the material browser to see if it's using one or not. Other textures might be massively under or over scaled, in both cases would make them look like a solid texture. This can happen if you rescale a component and then later change texturing. When you explode the component, you should see the texture scaling change, and will be able to fix the scaling. --Jefe (talk) 20:37, 23 March 2013 (UTC)

Why do some textures appear completely transparent and let you see the skybox, even if there are other things behind it? --Bcphoton (talk) 12:39, 17 April 2013 (UTC)


Could I get some help for the textures of this course? I can't seem to figure out what could possibly be wrong. In the model for Sketchup, everything appears normal. But when I import it to the SZS file, it ends up looking bad. I have checked the faces and they are being used by textures, but the texture doesn't show up. Is there a tool that could automatically fix it? The model can be found here: http://www.mediafire.com/?16i7m009zh3j1ow. Thank you so much! --Bcphoton (talk) 05:31, 20 April 2013 (UTC)


Is there any way to import the model with the SZS Modifier or Wiimms SZS Tools? I just wonder if that would help the texture problem. --Bcphoton (talk) 21:05, 24 April 2013 (UTC)