Talk:BrawlBox

From Custom Mario Kart
Revision as of 08:11, 14 July 2016 by Guilmon (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Im still unable to open a brres in CTools after I saved it with BrawlBox (if I have done a single change, even undoing that change results in a invalid file error in CTools) Vulcanus2 00:57, 22 January 2012 (CET)

BrawlBox writes a few invalid pointers to the mdl0 file. Open it in SZS Modifier and change the invalid ones to '00 00 00 00'. There's four of them. 0x28, 0x2c, 0x40 and 0x44. They will all start with an F*.
--Guilmon35249vr 03:26, 22 January 2012 (CET)

Im unable to open a custom mkw Brres in Brawlbox...why I can't open it? =/
LuigiM 14:55, 26 February 2012 (CET)

BrawlBox doesn't like certain files: namely PAT0 and SRT0 files. Try deleting them with CTools first. --Digital Monster, Guilmon35249vr 17:13, 26 February 2012 (CET)
I deleted them before I opened it with Brawlbox...It can only load Nintendo's SZS.
LuigiM 19:16, 26 February 2012 (CET)

Now I managed to open a Brres with Brawlbox...but after editting I can't open it with Brres Editor...what should I do?
LuigiM 22:52, 20 March 2012 (CET)

I have an outdated version of BrawlBox and I wanted to use the recent version to fix the HPE in my track. However, the download link doesn't seem to work and just takes me to a blank Mediafire page. Does anyone have a 0.65c .zip that they could reupload to Mediafire and use as a new download link? --Dr. Tapeworm, certified wriggling abberation. 20:22, 26 March 2012 (CEST)

Try this out http://www.mediafire.com/?9r3zxxubiq6r57j
LuigiM 12:54, 27 March 2012 (CEST)

Brawl Box can also open BRSAR Files but can't edith them. FloMaster35000vr 12:21, 14 April 2013 (CEST)

I heard that a new Brawlbox update is on the way which allows BRSAR editing :) -- WorldsBoss (talk) 10:27, 12 April 2013 (UTC)
There's supposed to be a lot of neat little extra features, such as the mini-model viewer in the main program, rather than within the model viewer itself. Of course, it's mainly useful for checking what model is what and how it looks like before opening it in the model viewer, in my opinion. -- ALPHAMARIOX 5:46, 12 April 2013 (MST)

Sound Effect Bugs

does anyone else get this problem for some reason piranha plants make a coin sound instead of a chomp sound and goombas walking noise is the lakitu yelling at you that your going backwards who else is getting this? --Soarin MKWII (talk) 08:42, 11 May 2013 (UTC)

ERROR

Hi i tried to fix a Harry Potter Effect in a ct with brawlbox and everytime i open any brres and go to mdl0 it crashes !!!! i tried different versions of brawlbox(i tried with 0.67, 0.67b and 0.68b) and different brres files and it always crashes! What is this? what is the problem???--Buschkling (talk) 06:00, 13 May 2013 (UTC)

Make all of your textures 256x256 and try again. --NewSuperMoiWii (talk) 11:15, 5 July 2014 (UTC)

0.68c Download?

where is it i click on downloads and for some reason it only shows up to 0.68b

--Soarin MKWII (talk) 03:22, 30 May 2013 (UTC)

For some reason, the google downloads site is not yet up to date. In the mean time, you can still download by clicking the link at the bottom of the box on the right. --James (talk) 07:16, 30 May 2013 (UTC)

What is new or what is fixed? Mkwjason (talk) 20:35, 30 May 2013 (UTC)

Did you click the download on this page, click the link after "Thread:", and then click "Show Spoilers" under the "Change Log" section?
-- Have a nice day, from ZillaSpaz 21:44, 30 May 2013 (UTC)

the "have a nice day" wasnt necessary but i found it and there is no "change log" section --Soarin MKWII (talk) 23:42, 30 May 2013 (UTC)

It's my signature. You should know about those; you advertised your Custom Track Distribution (and not putting your username) on it. Anyway, it is kinda there. http://prntscr.com/17hlw8
-- Have a nice day, from ZillaSpaz 23:57, 30 May 2013 (UTC)

.DOL and .BRSAR fixings

these definitely need to be fixed still the sounds of goobas and plants are switched for some reason and i opened the main.dol and it works after a while and then freezes so it should be fixed --Soarin MKWII (talk) 23:43, 30 May 2013 (UTC)

BrawlBox Crash

When I try to replace the texture references of my Psea model with those from Old_peach_gc, BrawlBox seems to stop working and automatically close. FunkyBones (talk) 04:27, 11 December 2013 (UTC)

Use an older version like 0.67b Mkwjason (talk) 13:50, 14 December 2013 (UTC)

How can I enter comma numbers?

How can I enter comma numbers, e.g. a comma scale number for a material?
--4TLPati (talk) 14:20, 14 July 2014 (UTC)

Change the decimal separation format from comma (,) to dot (.) in the Control Panel.
--maczkopeti (talk) 15:38, 14 July 2014 (UTC)
Thanks, worked perfectly :D
--4TLPati (talk) 15:57, 14 July 2014 (UTC)

BrawlBox v0.71 messes up textures - solid colors appear

I changed some material settings for an animation in BrawlBox v0.67b. After I opened it in v0.71, I changed some material settings again. When I load the track in game, all textures are solid colors (yes, the scale in the material is set to (1.1)). How can I fix this?
--4TLPati (talk) 10:17, 20 July 2014 (UTC)

Set "ForceRebuild" and "ForceFloat" to "True" in all UV entries
--maczkopeti (talk) 16:55, 20 July 2014 (UTC)

Crash when opening course_model.brres

I tested BrawlBox to edit a course_model.brres, but as soon as I open the 3DModel, BrawlBox crashes with "Entry point 'glGetUniformLocation' not found in 'opengl32.dll'". Even when I added that file to the BrawlBox folder, it still crashes. Do I need to install something else? -- Leseratte (talk) 13:49, 5 January 2016 (UTC)

This only occurs with models made with CTools BRRES Editor. To fix it, just open the BRRES in BRRES Editor and save it.
--maczkopeti (talk) 17:06, 5 January 2016 (UTC)

.chr0 animation problems

For the current character I am working on I've editted the boneset in 3ds Max 2015 as the proportions weren't right and as a result I've had to edit the animations so the character looks correct. The animations look fine in BrawlBox v0.77 but when testing in game, on the Wii, if for instance the character finishes his jump animation before he hits the floor when falling, it will go into a random, deformed pose for the remainder of the fall. Is this an issue with BrawlBox or am I missing something when editting animations? --Slawter (talk) 11:31, 27 June 2016 (UTC)

The armature coordinates in the animations must contain the same coordinates as the as the static model - that is, the first frame of each animation must have the same transition, scale, and rotation as the model does when static for each bone. Otherwise, the game will read everything as being un transitioned, and everything will "fly" to 0,0,0. Unfortunately, whereas other games will automatically calculate the offset based off of the static position, it appears Mario Kart Wii does not, while BrawlBox does (It does only when playing the animation - it does not save this information). In further unfortunance, your existing animations are useless - They're offset from 0,0,0 , and not the model's actual position (You could take the amount offset from 0,0,0 and add that to the model's default position per frame, but that may be a lengthy operation). Though BrawlBox does not display this offset error, BRRES Viewer does.
Information on the model's default orientation can be found per-bone under "bones", or in the non-existent "frame 0". As long as each animation begins with these offsets, you should be fine. What I do is I generate a one frame animation with this information, then use it as a base for each new animation. --SuperMario64DS (talk) 03:47, 28 June 2016 (UTC)

One polygon incorrect after importing

After importing a model from Autodesk Maya into BrawlBox v0.77 (a character), one of the polygons are messed up. It is heavily scaled down and distorted, and then moved to the origin (Despite it being skinned to the joints). It's not even in any shape where I can use BrawlBox's own model editing tools to get it back into a decent position.
Its UV map, colors, materials, and shaders all import fine, but it looks like it gets scrambled when figuring out which faces belong to which vertices, and where the vertices were to start with...
I've done "Freeze Transformations" and "Delete Non-Deformer History" on everything and only that one polygon is messed up. For reference, its my character's eye polygon.
I've tried different settings and different versions of the Collada exporter and I can't get it to work. Anyone who uses Maya for modding know what's going on?
--Guilmon35249vr (talk) 06:15, 13 July 2016 (UTC)

I got it working. I had to manually add in references to normals for each individual triangle since, although Maya connected the normals to polygon0 properly, it refused to connect them to polygon1, resulting in Brawlbox reading normals as vertex locations, which explains the distortion. I had to look at the triangles list, work out that "hey, there are 3 numbers for each triangle in this one but 4 for the other polygon..." so it turned out it was easy but time consuming. Anyway, my model works fine now. Who knew collada was so picky that just leaving out normals would mess up the whole thing?
--Guilmon35249vr (talk) 08:08, 13 July 2016 (UTC)
BrawlBox is actually giving lot of problems with this. When I import a custom character, it works on Dolphin Emulator but freezes on Wii, for an unknown reason, and this happens with the 50% of my custom characters. —Atlas (talk) 12:22, 13 July 2016 (UTC)
The newer BrawlBox versions are not exactly the best for MKWii. I use v0.68d for pretty much everything and v0.71 for optimization.
--maczkopeti (talk) 18:14, 13 July 2016 (UTC)
My character works fine on console but has shader issues on, again, only one polygon. It seems like it struggles to handle more than one polygon at a time?
EDIT: It turns out it was a corrupted color node. Fixed it in a hex editor and now his shaders are looking pretty good.
Any idea what would cause his texture to glitch out when viewed from the side?
--Guilmon35249vr (talk) 00:51, 14 July 2016 (UTC)