Importing 3D models

From Custom Mario Kart
Jump to: navigation, search
Under Construction
This article is not finished. Help improve it by adding accurate information or correcting grammar and spelling.
Software that you will need in this tutorial
SZS Modifier: Download
WiiScrubber: * Download.
Wiimms ISO Tools: ** Download
Dolphin Emulator Download
A 3d modeling program Google Sketchup: recomended
#Sketchup plugins: Obj importer
Legend: * and **: alternative softwares
# you don't need really this software.

Now you'll see how to extract the original Nintendo files of your Mario Kart Wii ISO and how to import the model to a 3D modeler editor.

Exporting the Mario Kart Wii ISO files

The file names

See Filesystem/Race/Kart

la_bike = Flame Runner
la_kart = Offroader
lb_bike = Wario Bike
lb_kart = Flame Flyer
lc_bike = Shooting Star
lc_kart = Piranha Prowler
ld_bike = Spear
ld_kart = Jetsetter
ldf_bike = Standard Bike L
ldf_kart = Standard Kart L
ldf_bike_blue = Standard Bike L (Battle Mode + Blue Team)
ldf_bike_red = Standard Bike L (Battle Mode + Red Team)
ldf_kart_blue = Standard Kart L (Battle Mode + Blue Team)
ldf_kart_red = Standard Kart L (Battle Mode + Red Team)
le_bike = Phantom
le_kart = Honeycoupe

ma_bike = Mach Bike
ma_kart = Classic Dragster
mb_bike = Sugarscoot
mb_kart = Wild Wing
mc_bike = Zip Zip
mc_kart = Super Blooper
md_bike = Sneakster
md_kart = Daytripper
mdf_bike = Standard Bike M
mbf_kart = Standard Kart M
mdf_bike_blue = Standard Bike M (Battle Mode + Blue Team)
mdf_bike_red = Standard Bike M (Battle Mode + Red Team)
mdf_kart_blue = Standard Kart M (Battle Mode + Blue Team)
mdf_kart_red = Standard Kart M (Battle Mode + Red Team)
me_bike = Dolphin Dasher
me_kart = Sprinter

sa_bike = Bullet Bike
sa_kart = Booster Seat
sb_bike = Bit Bike
sb_kart = Mini Beast
sc_bike = Quacker
sc_kart = Cheep Charger
sd_bike = Magikruiser
sd_kart = Tiny Titan
sdf_bike = Standard Bike S
sdf_kart = Standard Kart S
sdf_bike_blue = Standard Bike S (Battle Mode + Blue Team)
sdf_bike_red = Standard Bike S (Battle Mode + Red Team)
sdf_kart_blue = Standard Kart S (Battle Mode + Blue Team)
sdf_kart_red = Standard Kart S (Battle Mode + Red Team)
se_bike = Jet Bubble
se_kart = Blue Falcon

Variables of file names

At the end of the names above

-bds = Baby Daisy
-bk = Dry Bowser
-blg = Baby Luigi
-bmr = Baby Mario
-bpc = Baby Peach
-ca = Birdo
-dd = Diddy Kong
-dk = Donkey Kong
-ds = Daisy
-ds3 = Daisy (Biker Outfit)*
-fk = Funky Kong
-jr = Bowser Jr.
-ka = Dry Bones
-kk = Toadette
-ko = Toad
-kp = Bowser
-kt = King Boo
-la_mii_f = Large Mii Outfit A (Female)
-la_mii_m = Large Mii Outfit A (Male)
-lb_mii_f = Large Mii Outfit B (Female)
-lb_mii_m = Large Mii Outfit B (Male)
-lg = Luigi
-ma_mii_f = Medium Mii Outfit A (Female)
-ma_mii_m = Medium Mii Outfit A (Male)
-mb_mii_f = Medium Outfit B (Female)
-mb_mii_m = Medium Mii Outfit B (Male)
-mr = Mario
-nk = Koopa Troopa
-pc = Peach
-pc3 = Peach (Biker Outfit)*
-rs = Rosalina
-rs3 = Rosalina (Biker Outfit)*
-sa_mii_f = Small Mii Outfit A (Female)
-sa_mii_m = Small Mii Outfit A (Male)
-sb_mii_f = Small Mii Outfit B (Female)
-sb_mii_m = Small Mii Outfit B (Male)
-wl = Waluigi
-wr = Wario
-ys = Yoshi

Exporting with WiiScrubber

Open Wii Scrubber, select the Mario Kart Wii ISO (on the button Load ISO), go to:

race » kart and choose your kart/character » click the right mouse button and select extract in the chosen file
WiiScrubber.ex.png

Exporting with Wiimms ISO Tools

Wiimms ISO Tools is a tool set with a command line interface, but there are also GUIs for the tools available.

Exporting with Dolphin Emulator
  1. Open Dolphin.
  2. Right-click on the Mario Kart Wii ISO and click "Properties".
  3. There will be 6 tabs on the top. Click on "Filesystem".
  4. If you want to extract a course or a Character go to "Race". Right-click on the file you want to extract. Then export it. Make sure you add the extension "SZS" to the file you extract.

On SZS Modifier

Opening the necessary files

Open The BRRES Model: driver_model.brres » open these files to expot the obj model:

  • model_load = the character (optional)

Open The BRRES Model: kart_model.brres » open these files to expot the obj model:

  • body = kart bodywork (necessary)
  • handle = handlebars / wheel (optional)
  • tire_f = tire (optional)
  • tire_r = tire (optional)
Exporting the obj model

On Model Editor of SZS Modifier Click: File » Export

To save the obj model in your computer.
Exporting from SZS Modifier.png

Importing to a 3D modeling editor

Getting Started

First you need open the notepad.

1:Click on: Edit » Replace
2:Find: , Replace with: .

Importing with Google SketchUp

In Google SketchUp go to:

Plugins → OBJ Importer → Import OBJ [No materials]

A window will appear, select the Option Meters.

Importing with Blender

When you first start Blender you can't import an OBJ File into it.

To fix that go to:

  • File → User Preferences → AddOns → Select the "Import/Export" Layer → Make a Tick at "OBJ File Format".

After this, click on "Save as default" and restart Blender. Now you can import OBJ Files in Blender (File → Import → OBJ).

Importing with 3d Studio Max (3ds Max)
Editing this tutorial

You can edit this tutorial as long as you make sure you're right.

Incorrect information will harm the people who read this tutorial, if you have questions, write on discussion on this page.